IPv4 over IPv6 OCNバーチャルコネクトで AR1050v設定してみる-設定途中

OCNバーチャルコネクト接続できず

すみません。この記事書きかけで、アライドのAR 1050v でOCNバーチャルコネクト接続できるところまでは至っていません。

とりあえずこのページに記載した設定ではインターネット接続を確認できず、 AirStation WXR-1750HP2 でOCNバーチャルコネクト接続したらあっさりつながって。時間切れでそのままAirStationでやっています。

玄人だなぁ

AR1050vは玄人向けだなぁと思います。

最初からweb GUIが搭載されていなかったり。価格が安いのはいいのですが、めちゃくちゃとっつきにくい。

最初の設定からして、WAN側にLANケーブルを差し込まなければ SSH接続で192.168.1.1で接続できるっていうのもすごいですね。それもDHCPサーバ稼働していないんで、パソコンのIPアドレスを192.168.1.0/24に設定しておかないといけないです。

OCNバーチャルコネクト

設定例

!
interface eth1
 ip dhcp-client default-route distance 254
 ip address dhcp
 ipv6 dhcp client pd IPoE
!
ipv6 dhcp pool IPoE-vlan1
 dns-server interface vlan1
!
interface vlan1
 ip address 192.168.10.1/24
 no ipv6 nd suppress-ra
 ipv6 nd other-config-flag
 ipv6 address IPoE ::/64 eui64
 ipv6 dhcp server IPoE-vlan1
!
ipv6 forwarding
!
ip dhcp pool pool10
 network 192.168.10.0 255.255.255.0
 range 192.168.10.100 192.168.10.131
 dns-server 192.168.10.1
 default-router 192.168.10.1
 lease 0 2 0
!
service dhcp-server
!
softwire-configuration NTT-COM
 method proprietary
 map-version draft
 upstream-interface eth1
 vendor-name NTT-COM
!
interface tunnel0
 tunnel softwire NTT-COM
 tunnel mode map-e
 ip tcp adjust-mss pmtu
!
ip route 0.0.0.0/0 tunnel0
!
zone ipv4-internal
 network dhcp
  ip subnet 0.0.0.0/0 interface vlan1
 network hgw
  ip subnet 0.0.0.0/0 interface eth1
 network lan
  ip subnet 192.168.10.0/24 interface vlan1
!
zone ipv4-internet
 network wan
  ip subnet 0.0.0.0/0 interface tunnel0
  host nat
   ip address dynamic interface tunnel0
!
zone ipv6-internal
 network lan
  ipv6 subnet ::/0 interface vlan1
  host vlan1
   ipv6 address dynamic interface vlan1
!
zone ipv6-internet
 network wan
  ipv6 subnet ::/0 interface eth1
  host eth1
   ipv6 address dynamic interface eth1
!
application dhcpv4
 protocol udp
 dport 67 to 68
!
application dhcpv6
 protocol udp
 dport 546 to 547
!
application icmpv6
 protocol ipv6-icmp
!
firewall
 rule 10 permit dhcpv4 from ipv4-internal.dhcp to ipv4-internal.dhcp
 rule 20 permit any from ipv4-internal.lan to ipv4-internal.lan
 rule 30 permit any from ipv4-internal.lan to ipv4-internet
 rule 40 permit any from ipv4-internet.wan.nat to ipv4-internet
 rule 50 permit any from ipv4-internal.hgw to ipv4-internal.hgw
 rule 100 permit any from ipv6-internal to ipv6-internal
 rule 110 permit any from ipv6-internal to ipv6-internet
 rule 120 permit any from ipv6-internet.wan.eth1 to ipv6-internet
 rule 130 permit icmpv6 from ipv6-internet to ipv6-internet.wan.eth1
 rule 140 permit dhcpv6 from ipv6-internet to ipv6-internet.wan.eth1
 protect
!
nat
 rule 10 masq any from ipv4-internal to ipv4-internet
 enable
!
ip dns forwarding
!
end